Linux下 netbeans 安装提示找不到对应的jdk的解决办法

作者: 杨圣亮 分类: 开源软件 发布时间: 2016-10-19 18:14:19

已经安装了jdk1.8.0_77版本的jdk,并已经设置为默认jdk,系统中存在openjdk7,oracle jdk1.8,启动netbeans安装程序,提示找不到对应的jdk。网上搜索一下,原来netbeans安装有个javahome参数,就是专门解决多版本jdk的选择问题的。

解决办法,运行 安装文件:netbeans.xx.sh时指定javahome参数,这样,也可以在系统中存在多个版本的jdk时。没有安装jdk的朋友请参照文章: Linux 搭建 jdk1.8 java开发环境

系统环境

操作系统:ubuntu 14.0.4

netbeans8.1:netbeans-8.1-linux.sh

java 1.8安装目录:/data/opt/jdk1.8.0_77

进入netbeans文件目录

终端下运行命令:

sudo ./netbeans-8.1-linux.sh --javahome  /data/opt/jdk1.8.0_77

问题解决!

       

如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。

+ 85 = 九十 一

微信